设为首页收藏本站

AnyChat技术支持论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 3054|回复: 0

2016-02-15 兼容Android 5.1.1内核

[复制链接]

242

主题

2960

帖子

8945

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
8945
发表于 2016-2-15 21:34:15 | 显示全部楼层 |阅读模式
AnyChat r5399版本兼容Android 5.1.1内核。

早期的AnyChat SDK在Android 2.x、4.x以及6.x版本上均工作正常,但在Android 5.1.1内核上存在较大几率出现OnConnect(errorcode=100)的情况,现象为连接服务器失败,经过研发团队的调试分析,发现这是由于Android 5.1.1内核在处理Socket异步消息时存在缺陷所致,经过修改AnyChat的底层代码,最新的版本已经规避该缺陷,在Android 5.1.1上可以正常工作。

上层应用的源代码不需要修改,只需要更新Android SDK(参考:AnyChat版本升级步骤指南),重新编译工程生成新的apk即可,服务器程序不需要更新。

如果您使用的最新版本,则请重新下载AnyChat for Android SDK。如果您使用的是V5.3及以前的旧版本,您可以下载补丁库: anychat_libs_5.3_r5399_patch.zip (677.16 KB, 下载次数: 2962)
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|AnyChat ( 粤ICP备13022410号-1 )  

GMT+8, 2021-4-12 11:07 , Processed in 0.585399 second(s), 30 queries .

Powered by Discuz! X3

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表