设为首页收藏本站

AnyChat技术支持论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 355|回复: 0

2018-08-20 适配最新移动端平台,全面兼容iOS 12

[复制链接]

222

主题

3011

帖子

8808

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
8808
发表于 2018-9-15 17:43:23 | 显示全部楼层 |阅读模式
iOS 12将于2018年9月正式推送,AnyChat研发团队在iOS 12 preview版本上进行了全面的优化与验证。

早期的版本在XCode 10上编译时,会提示Link错误,原因是苹果在XCode10中移除了libstdc++这个库,由libc++这个库取而代之,官方强制要求所有开发者使用经过了llvm优化过并且全面支持C++11的libc++库。AnyChat新版本也对此进行了适配,新的SDK库文件全面支持libc++。修正方法:在Link库中去掉 libstdc++.6.tbd,增加libc++.tbd(详见:AnyChat兼容XCode 10指南

新版本同时修正在部分iPhone6机器上运行不正常的问题,兼容性更好。





回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|AnyChat ( 粤ICP备13022410号-1 )  

GMT+8, 2018-11-18 18:39 , Processed in 0.168686 second(s), 23 queries .

Powered by Discuz! X3

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表